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What you will do:

4 Start
FrontPage 2000.

4 Explore the
FrontPage 2000
main window.

4 Start a Web site
by creating a new
page.

4 Become familiar
with the different
ways to view your
work in FrontPage
2000.

Getting Your BearingsGetting Your Bearings

FrontPage 2000 makes it easy for you and your students to create a Web site. With
FrontPage 2000, you can create the structure or layout of your Web site, apply
graphical themes to its pages, and organize its files and folders. You can import and
export files, test and repair hyperlinks, track tasks, and design and edit the contents
of your Web pages. When your Web is completed, use FrontPage 2000 to publish it
on your computer, your organization's intranet, or the World Wide Web.

As you add components such as text, images, tables, and form elements, FrontPage
2000 displays them as they would appear in a Web browser. Although it is a powerful
tool, FrontPage 2000 is easy to use because it looks much like a word-processor. You
do not need to learn Hypertext Markup Language (HTML) to use FrontPage 2000
because it creates all the HTML code for you. You can click the HTML tab at the
bottom of the page to view and directly edit the code, and then click Normal for
“What you see is what you get” (WYSIWYG) format. Also, the Preview tab lets you see
what your Web site looks like in the browser.

Before you beginBefore you begin

To get an idea of how you want your Web site to look, it is a good idea to look at
outstanding Web sites that other people have created. Look at these sites for good
examples of Web design and organization.

• The United States Department of Education at http://www.ed.gov/

• The University of Washington at http://www.washington.edu/

• The United States Information Association at http://www.usia.gov/

Several organizations give awards for outstanding Web sites. The following two Web
sites are examples of this type of Web site. Visit them for examples of what Web
users like to see:

• Best of the Web at http://www.botw.org/

• Internet Professional Publishers Organization at http://www.ippa.org
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Starting FrontPage 2000Starting FrontPage 2000

This lesson walks you through opening FrontPage 2000, viewing the screens and
toolbars, and creating your first Web page using FrontPage 2000. When you have
finished this lesson, you will have a simple Web site with a template attached.

To start FrontPage 2000To start FrontPage 2000

1. Turn on your computer.

2. On the Windows Taskbar, click Start, point to Programs, and then click
Microsoft FrontPage. FrontPage 2000 opens in Page view.

Exploring the FrontPage 2000 windowExploring the FrontPage 2000 window

Finding your way around FrontPage 2000 is easy once you know the location of
folders and files and the navigational techniques. To give you greater control over
how your Web pages turn out, FrontPage 2000 offers six different views of the
current FrontPage 2000 Web. When you open FrontPage 2000 the first time, you see
the Page view window. The toolbars and scroll bar you see are available for all six
views.

Views toolbar
Click to see your
Web site in the
different available
views.

Tabs
Click to see your Web page in
Normal (WYSISYG) format, HTML
coding, or a preview of what the
page looks like in the browser.

Scroll bars
Use these to move up and
down or across your Web
page.

Standard toolbar
Formatting toolbar
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Working with the FrontPage 2000 toolbarsWorking with the FrontPage 2000 toolbars

Three toolbars are available in Page view when you open FrontPage 2000 for the
first time.

Menu toolbar

The Menu bar contains a list of menus that help you create, edit, and format
Web pages in FrontPage 2000. As you click each menu, additional options
appear. Each option shows you more choices, depending on what you are doing.
If a menu option looks faded (is grayed out), the option is not currently available
to you, but are available for other activities. If you see a chevron  at the bottom
of the menu, click it and the rest of the menu options appear. The options you
use most are promoted to the top of the menu.

Standard toolbar

The Standard toolbar contains buttons that give you quick access to FrontPage
2000's most commonly used functions, such as opening, saving, and printing.

Click to create, open,
save, or send a
document as e-mail.

Print a document,
preview printing,
or check spelling.

Undo or redo
any action.

Insert a
hyperlink.

Show or hide
markers.

View the list of
folders used in
your Web site.

Cut, copy, and paste
objects, text, or styles.

Add components,
create tables, or
add graphics.

Refresh the
page or stop
a jump.

Ask the Answer
Wizard for help.

Formatting toolbar

The Formatting toolbar contains buttons that allow you to format text and
paragraphs on your Web pages.

Format paragraph styles
on your Web page.

Change the
font size.

Right justify, center,
or left justify text.

Highlight text or
change the font color.

Change fonts on
your Web page.

Format fonts as bold,
italic, or underlined.

Format text as a numbered
or bulleted list, and move
the indentation in or out.

Explore the Menu toolbar by clicking on each of the
menus. For example, click Tools to see the options
in the Tools menu.

Arrows indicate that there are
additional options for this menu
item.

The chevron means more
options are available.
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Creating a WebCreating a Web

A Web is any document or set of documents you can view on the World Wide Web. A
Web can be a single page or an entire Web site. Web pages are individual HTML files
that stand-alone and have their own address (URL) on the Web. Web sites are related
collection of pages, including a beginning file called a home page. From the home
page, you can navigate to all other pages on the site.

Begin creating your Web site by building a home page in FrontPage 2000. This is the
“front door” to your Web site and should include a greeting, a short explanation of
what the Web site is for, and links to the rest of the Web site. For this exercise, you
will create a school Web site, so your home page is an introduction to the school and
related Web pages. You can then use the same skills to create a homepage for a
class you are teaching, whether you teach online or in person.

To start building a WebTo start building a Web

1. Start FrontPage 2000 if it is not already open. When you open FrontPage
2000, you see the Page view.

2. On the Standard toolbar, click the arrow next to the New button and
then click Web. The New dialog box appears.

3. On the Web Sites tab, click Empty Web, and then click OK. The Folder
list appears between the Views menu and the page.

4. On the Views menu, click . Because you have not yet added any
pages, the Navigation view is blank. Click  to add a home page.

5. Right-click the home page icon and click Rename, then type Central
High School Home Page. This is the text that appears at the top of the
page.

6. To add connecting pages to your home page, click the home page and
then click  five time to add five pages. The pages appear under the
home page.

7. Right-click New Page 2, and click Rename. Type Calendar of Events.

8. Repeat step 7 with the other new pages and name them Departments
and Faculty, Academic Requirements, Alumni Activities, and Educational
Links.

Click the arrow next to the New button.

Then, click the New Web button

Microsoft also provides
templates for several types
of Web sites. Try
experimenting with the
templates to find one that
suites you.
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Adding tools to get around a WebAdding tools to get around a Web

To make it easier for people to find information on your Web, add navigational
tools. The easiest way to do this is by adding shared borders. Shared borders are
regions that are common to one or more pages in a web. A shared border may be
a region at the top of the page (similar to a page header), at the bottom (similar
to a page footer), at the left, or at the right. With shared borders, you can easily
add a logo or navigation buttons at the top of each page because you must only
add the information once and it appears on all pages sharing the same border.

To add shared bordersTo add shared borders

1. From the Navigation view, double-click the Calendar of Events page.

2. On the Format menu, click Shared Borders.

3. Select the All Pages option, then select the Top, Left, and Bottom
checkboxes.

4. Select the Include navigation buttons checkbox below the Left option
to add links to all the pages in your Web, and then click OK. Dotted lines
appear on the Web page to indicate where shared borders are located.

5. Click in the top shared border area. The text is highlighted.

6. On the Insert menu, click Page Banner.

7. Select the Picture option, verify that Calendar of Events is in the Page
banner text box, and then click OK. The title Calendar of Events can now
be seen in the top shared border.

8. Click in the left shared border area. The text is highlighted.

9. On the Insert menu, click Navigation Bar.

10. Select the Same level option, then select the Vertical, and Text options
and click OK. Hyperlinks to each of the Web pages below the home page
are now located in the left shared border.

11. Click on the bottom shared border area. The text is highlighted.

12. On the Insert menu, click Navigation Bar.

13. Select the Top level option, then select the Horizontal and Text options
and click OK. The title Central High School Home Page can now be seen
in the shared border at the bottom of the page.

You now have a very simple Web site with navigational links between pages. With
a Web site under construction, you can now get to know each of the FrontPage
2000 views.
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Become familiar with the FrontPage 2000 viewsBecome familiar with the FrontPage 2000 views

Once you have a Web site under construction, you can view the site in any of the six
available views.

Page View. Create and edit individual pages. Page view also allows you to
see your content in Normal (WYSIWYG), Reveal Tags in Normal, HTML, or
Preview in browser views.

Folders View. View the organization of all the Web pages, graphics, and files
in your Web.

Reports View. See pages, graphics, and files in your Web, and run reports
listing slow pages, unlinked, errors, status, recently added or changed files,
broken hyperlinks, or categories for any of the files.

Navigation View. Create navigation bars, view the navigational layout of the
site, preserve settings across editing sessions, and zoom in to work on
specific parts of the site.

Hyperlinks View. See all of the items that link to or from a specific page or
Microsoft Office document, and visually see if any links are broken.

Tasks View. Track what tasks need to be done and to whom the tasks are
assigned, and quickly see the status, description, and the priority of the
tasks.

In the following sections you’ll get a more in-depth look at each of the views and see
how they help you work better as you build a Web site.
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Working with content in Page viewWorking with content in Page view

The actual writing of the Web pages occurs in Page view. You can add content,
add graphics, effects, and motion clips to pages, as well as apply a theme and
check spelling and grammar.

To explore the Page viewTo explore the Page view

1. On the Views toolbar, click the Page button. You see the current page
you have been working on with the Normal tab selected. You can edit a
Web page in Page view much like you would edit a document in
Microsoft Word.

2. In the Folder List, double-click central_high_school_home_page, click in
the area to the right of the left shared border, and then type Welcome to
the Central High School Home Page!. Select the text by dragging over it
with the pointer, and then click . If you do not see the Folder list, click

.

3. With the text still selected, change the font by selecting Comic Sans MS
from the Font drop-down list and change the font size by selecting 4 (14
pt) from the Font Size drop-down list

4. Click the HTML tab. This tab shows you the HTML code that determines
what the page looks like in the browser. If you know HTML code, you can
edit your Web page directly in the HTML code.

5. Click the Preview tab. Here you see the Web page as it looks in the
browser. Use the scroll bar on the right to see the bottom of the page.

Dotted lines indicate shared
borders.

Text you add in the active
page with font and size
changed.

The hyperlink to the home
page that you added.

This is Page view with the
Normal tab selected.
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Organizing a Web with the Folders viewOrganizing a Web with the Folders view

Folders contain the organization of the contents of files and folders in the Web.
You can create, delete, copy, and move them in the Folders view.

To explore the Folders viewTo explore the Folders view

1. On the Views toolbar, click the Folders button. You see the folders for
your School Web site. Because you have not created all the pages, you
do not yet have many folders.

2. In the Folders List pane, click images.htm.

3. In the right pane, view the contents of the images folder. Because you
have not yet added any graphics to your Web, this folder is empty.

As your Web site becomes larger and more complex, you will see more
folders in the Folder list and they will contain more information. Examples of
files that FrontPage 2000 adds to the folder list include the following:

• Global.asa  contains information about the Web’s data connection
for use with database functions.

• Animate.js  contains Dynamic HTML animation effects.

• Fphover.class  contains hover buttons added to Web pages.

Folder List
Shows the file structure
of the Web folder.

Contents
Shows the selected Web
folder's contents.
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Retrieving information about your Web with Reports viewRetrieving information about your Web with Reports view

All Webs contain a list of files in the project's folders. The list provides
information such as file names, sizes, types, number of links, types of links, and
modification dates.

To explore the Reports viewTo explore the Reports view

1. On the Views toolbar, click the Reports button. A list of report topics
appears in the left column.

2. Double-click Recently added files. The list of files you just created
appears.

3. Click Title to sort the hyperlinks by page title.

4. On the Views menu, click Reports, and then click Site Summary to
return to the summary page in the Reports view.
-Or-
On the Reports toolbar, select Site Summary from the Report drop-
down list.

Reports view alerts you to possible problems in your Web site. As you
continue to work on your Web site, the reports become more useful. You are
able to see broken hyperlinks in your Web site, which pages take too long to
download, and which tasks are incomplete.

The name of the report.

The number of effected
files.
The size of the files.

A description of the
report type.

The Reports toolbar
helps you move between
different reports.
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Maintaining site navigation with Navigation viewMaintaining site navigation with Navigation view

The Navigation view shows you a display of the structure of your Web. You can
create, display, and print this Web structure. If there is more than one page box,
you can click the + (plus sign) in the Home page box to open it; if there is a –
(minus sign), click it to close the Home box.

To explore the Navigation viewTo explore the Navigation view
1. On the Views toolbar, click Navigation.

2. Click the Central High School Home Page page. Notice that the
selected page is blue, while the others are yellow.

3. In the Central High School Home Page page, click - to collapse the
Web, then click + to expand the Web again.

4. Click and hold the Alumni Activities page, and then drag it under the
Calendar of Events page. Any changes you make in this view effect the
pages in Page view, so click and drag the Alumni Activities page back
to its original place.

5. On the Navigation toolbar, select 150% from the Zoom drop-down list.
Notice that you can view a select portion of the Web and use the scroll
bar to view the rest of the Web. You can also select Size To Fit to view
the entire Web, regardless of how big it is.

6. From the Navigation view, you can also double-click a page to see it in
Page view.

The Navigation toolbar
allows you to view the
navigation structure at
different percentages. Also,
the external link button on
the Navigation toolbar allows
you to add links to pages
outside your Web to your
navigation structure.

The minus sign shows you
there are pages below this
page and that all the pages
are visible.
The navigational structure of
your Web is represented with
a tree structure.
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Managing hyperlinks with Hyperlinks viewManaging hyperlinks with Hyperlinks view

In the Hyperlinks view, you can view the Web pages in the left pane and the
hyperlinks in the right pane. The page graphically displays hyperlinks between
pages, between files in your FrontPage 2000 Web, and from your Web to other
sites on the World Wide Web.

To explore the Hyperlinks viewTo explore the Hyperlinks view

1. On the Views toolbar, click Hyperlinks.

2. In the Folder list, click central_high_school_home_page.htm. This shows
you all the links to and from the Web page.

3. In the left pane, click the + in front of calendar_of_events.htm. This
expands the view of hyperlinks to that Web page. A page without a + or a
- does not have any additional hyperlinks.

4. Click the - in front of calendar_of_events.htm to close.

5. Right-click calendar_of_events.htm, and then click Move to Center. This
makes calendar_of_events.htm the center of the Hyperlinks view.

Pages that link to the
selected page.
The selected page.

Pages to which the
selected page links.
A  ++  (plus sign)
indicates that the
page has additional
links.
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Monitoring tasks in Tasks viewMonitoring tasks in Tasks view

With the Tasks view, you can generate and keep track of a list of tasks to
complete your FrontPage 2000 Web. You can create new tasks, assign them to
specific pages, and track their progress. Use this view to display the status of
Web tasks before you publish your Web. Prior to your creating and assigning
tasks, Tasks view is empty.

To explore the Task viewTo explore the Task view
1. On the Views toolbar, click Tasks.

2.1. On the Standard toolbar, click the arrow next to the New button and
then click Task. The New Task dialog box appears.

3.2. In the New Task dialog box, type Create School Logo.

4.3. Type John Doe in the Assigned To box.

5.4. Under Priority, select the Medium option.

6.5. In the Description box, type find a school logo image, and then click
OK. The task appears in the Task view with a red dot next to it to
indicate that it is not yet complete. Green dots appear next to completed
tasks.

Click the arrow next to the New button.

Then, click the New Task button

Click these buttons to
sort the tasks.
Each task appears in
the Task view with a
dot indicating whether
the task has or has not
been completed.
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Extending your knowledgeExtending your knowledge

Many features of FrontPage 2000 are described in this book, and there are many
more that you can explore on your own. To learn more about any feature in FrontPage
2000 use the Answer Wizard.

Exploring FrontPage 2000 HelpExploring FrontPage 2000 Help

Use the FrontPage 2000 Help command to get online help. To answer your
questions quickly and efficiently, the FrontPage 2000 help system has three
parts: Contents, Index, and the Answer Wizard. Contents is like a table of
contents where help is organized by chapters and subtopics. In Index, you type a
keyword that you want to find more information about. The Answer Wizard allows
you to ask a question using natural language, then generates a list of topics that
relate to your question.

To ask the Answer Wizard a questionTo ask the Answer Wizard a question

1. Click  to open the Answer Wizard.

2. Type your question in the box that appears. For example, type How do I
publish my Web site?

3. Click Search.

4. Select the topic that most accurately answers your question. The text
appears in the Help window.

5. To close the Answer Wizard, click the X in the upper-right corner of the
Answer Wizard's box.

Viewing ScreenTipsViewing ScreenTips

In addition to the Answer Wizard, ScreenTips can be a helpful tool in learning to
use FrontPage 2000. When you position the pointer next to any button on the
toolbars, a small box appears with the name of each button. The box is called a
ScreenTip.

Point to any toolbar button.

The Screen Tip appears.
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Closing FrontPage 2000Closing FrontPage 2000

To make sure that you do not lose any work you have done with FrontPage 2000,
always follow the proper procedures to close your file. If you plan to continue to
the next activity in this book, you do not need to close FrontPage 2000.

To close FrontPage 2000To close FrontPage 2000

1. Save your work by clicking Save .

2. On the File menu, click Exit.

3. If you did not save your work, click Yes to save.
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Designing a WebDesigning a Web

Now that you are familiar with how FrontPage 2000 works, you can get started on
your Web site. In this chapter you begin by designing your school Web site. When you
have a blue print in place, managing the site is much easier in the long run. Although
you can always return to a Web site and arrange pages after you have finished
creating the site, you may find it easier to manage the Web site if you plan ahead.

You also want visitors to your site to be able to navigate easily between pages on
your Web site without losing track of where they are. Good organization helps make
browsing a Web site fun, helps guarantee return visits, and hinges on good planning
and organization.

Before you beginBefore you begin

In order to create an outstanding Web site, you must first plan the types of content
and the types of Web pages you want on your Web site.

• Brainstorm about the types of content you want on your Web site. This can
include information about student activities and services, sports, academic
departments and advancement requirements, alumni activities, and more.

• Brainstorm about the types of links you want from your Web site. These can
include links to research resources, professional educator organizations,
and other educational sites.

• Begin an outline of your Web site.

This book shows you how to create a school home page with links to at least five
other pages. The pages used for these activities are:

• Calendar of Events

• Departments and Faculty

• Academic Requirements

• Alumni Activities

• Educational Links

What you will do:

4 Create an outline
for your Web site.

4 View the design of
a FrontPage Web.

4 Add and
customize a
theme.

4 Add and delete
pages.

4 Organize your
pages.

4 Decide which
browsers you
want visitors to be
able to use to
view your site.

4 Learn to track the
progress of the
Web site design
by assigning
status, author,
and categories.
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Organizing your Web’s structureOrganizing your Web’s structure

The home page serves as the gateway to a Web site, so you should organize your
Web site around it. Using the Navigation view in FrontPage 2000 to set up a
flowchart to group your pages, you can easily arrange your Web.

Determining a purposeDetermining a purpose

Just like any other task you may do, you need to know your Web site’s purpose
before you begin. In the case of a school Web site, you may want to publicize
school events, keep students up-to-date on deadlines and other activities, point
patrons to educational resources, or portray a positive image of the school to
your community.

Defining your Web site’s purpose helps you decide what kind of theme you want
to give the Web site, and what types of information to include on the pages.

Drawing an organization chartDrawing an organization chart

On paper, draw a simple organizational sketch of how the pages of your Web
should be placed in relation to one another. The home page is at the top, and the
rest of the pages are connected on one or more levels below the home page.

Counselors for
students A-M

Departments
Academic

Counseling
Page

Faculty

Home PageHome Page

Calendar
of Events

Page

Educational
Links Page

Alumni
Activities

Page

Academic
Requirements

Departments
and Faculty

Page

Counselors for
students M-Z
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Understanding good Web designUnderstanding good Web design

FrontPage 2000 allows you to add numerous themes, fonts, animations, effects,
sounds, graphics, and more. In order to create a well-designed Web site, you
should have an idea about what design elements you want to use to enhance the
look of your Web site.

Good Web design consists of the following:

• A well-organized structure

• Focused information

• Consistency between pages

• Easy navigation

• Well-maintained information and links

Understanding basic Web page designUnderstanding basic Web page design

In a well-designed Web site, visitors should always know where they are, and how to
get where they need to go. To make sure that people can find what they need in your
site, your pages should feature consistent layout elements. Applying basic page
design to your site helps make your site easier to navigate through and more
pleasant for people to visit.

The structure of a Web page includes a header, body or active page, and footer.

• The headerThe header, at the top of the Web page, can include a title, banner, shared
borders, or navigation bars that provide links to other pages.

• The bodyThe body  contains text stating the Web's purpose and provides information.
It can also include navigation bars, images, sound, motion clips, and other
links.

• The footerThe footer, at the bottom of the printed page, may include an address,
phone number, e-mail address, date of last update, hit counter, or links.

The header and footer usually look the same on most of the pages in a Web. The
easiest way to have the same information on each page is to use the Shared Border
feature in FrontPage 2000. Shared borders let you create the header and footer on
one page, and have automatically copy them onto other pages with in your Web. For
more information on shared borders, see the Getting Your Bearings chapter in this
book.
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Opening an existing WebOpening an existing Web

If you saved and closed the Central High School Web site that you began in the
previous chapter, you need to open the existing Web to continue working where you
left off.

To open an existing WebTo open an existing Web

1. Open FrontPage 2000.

2. Click the arrow next to the Open button, and click Open Web. The Open
Web dialog box opens to the Web you worked on most recently.

3. If you have not worked on any other Webs, click Open.
-or-
If you have worked on other Webs, browse through the folders to find
the Central High School Web, and then click Open.

The Web opens in Page view.

AddingAdding a design theme to your Web a design theme to your Web

A FrontPage 2000 theme consists of unified design elements and color schemes for
bullets, fonts, images, navigation bars, and other page elements. A theme gives the
pages and navigation bars in your FrontPage Web an attractive and consistent
appearance. After adding a theme, you can also modify the theme to represent your
organization, club, or school.

To add a themeTo add a theme

1. Double-click central_high_school_home_page.htm to open the home
page.

2. On the Format menu, click Theme.

3. In the Themes dialog box, select the All Pages option.

4. Select the Straight Edge theme. Straight Edge is a very simple theme.
To explore the other themes, click the title and a preview appears in the
Sample of Theme box.

5. Select the Active Graphics and Background Image check boxes.

6. Click OK. The theme is applied to all pages in your Web.

Click the arrow next to the Open button.

Then, click the Open Web button.
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Adding and deleting pagesAdding and deleting pages

After planning a Web site, you know what pages to include in your Web and where
they should be. You can always add and delete pages later, but plan the Web site
before you add pages. With a plan in place, you can more easily assign tasks and
pages to people who are contributing to your Web’s production. If you are working
alone, it is easier to organize tasks when the Web site is well planned.

To add a page to your WebTo add a page to your Web

1. On the Views toolbar, click  to go to the Navigation view.

2. Click the page to which you want to add a new page.

3. Click  to add the new page.

4. To name the page, right-click the new page and click Rename, and then
type the new page name.

To delete a page from your WebTo delete a page from your Web

1. On the Views toolbar, click  to go to the Navigation view.

2. Click the page you want to delete.

3. On the Edit menu, click Delete. The page no longer appears in the
Navigation view.

Organizing and managing pagesOrganizing and managing pages

FrontPage 2000 makes it easier than ever to manage the development of a complex
Web site by allowing you to easily move Web pages, assign, track, and update tasks,
and keep track of broken links, slow pages and old files.

Create tasks to track work that needs to be done in your Web. You can assign a task
to a specific person or workgroup, prioritize the importance of the task, and associate
the task with a specific file or the entire Web.

FrontPage 2000 monitors task status for you. When you save a page associated with
a task in Page view, FrontPage 2000 asks if you want to change the task status to
Completed. If you answer No, FrontPage 2000 changes the task status to In
Progress. You can also mark tasks as completed in Tasks view.
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To move a page within your WebTo move a page within your Web

1. Click the page you want to move.

2. Drag the page to the preferred location by clicking and holding the
mouse button down while moving the pointer to the new location.

To create a taskTo create a task

Use tasks to maintain and manage your Web. You can assign and prioritize tasks
and link them to pages, pictures, sounds, other Office documents, or any other
files in your Web.

1. In Page view, go to the Departments and Faculty page.

2. On the Standard toolbar, click the arrow next to the New button and
then click Task. The New Task dialog box appears.

3. In the New Task dialog box, in the Task name box, type Faculty
Extensions.

4. In the Assigned to box, type or select the name of the person you want
to assign the task to.

5. In the Description box, type Gather faculty phone extensions for use on
this page or other description of the task.

6. In the Priority area, click a priority for the task and then click OK.

To assign a taskTo assign a task

You can more effectively manage the workflow of your Web site by assigning
tasks to different students. You can assign a task to a person, a group, or
anything else that you can type or select in the Assigned To list.

• You can assign a task when you create it. Type or select a name in
the Assigned to box of the New Task dialog box.

• You can assign a task after you've created it. In Tasks view, click the
cell in the Assigned to column of the task you want to assign, click
the cell again, and then type or select a name. This overrides any
assignment made when the task was created.

• If a task has been marked as Completed, you can't reassign it.

If you create a task in Page
view while editing a page,
the new task is
automatically associated
with that page. To
associate a task with a
page or file in another view,
select the file, and then
create the task.

The Assigned To list is
shared with Reports view
for assigning files. In
Reports view, you can
assign a file to someone
without creating a specific
task.

Click the arrow next to the New button.

Then, click the New Task button
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Using check-out and check-inUsing check-out and check-in

When a group of students and educators work on a Web together, many people
create and edit Web content. When working in groups, there is always a danger
that two people could open and edit the same page, only to discover after the
fact that a conflict has occurred. FrontPage 2000 helps alleviate this problem by
adding page-level Check-In and Check-Out.

When you check out a file, only you can modify it. Other authors can open the
last-saved version of the file to view it, but cannot save any changes to it. This
means you no longer have to worry about one person over-writing another
person’s changes. After you check in a file that you have edited, other authors
can then check out the file and modify it.

Before you can check out a fileBefore you can check out a file

1. On the Tools menu, click Web Settings.

2. Click the General tab.

3. Select the Use Document Check-In and Check-Out checkbox.

4. Click Yes when asked if you want to proceed.

To check out a fileTo check out a file

1. In the Folder List in any view or in Folders view, right-click the file you
want to check out.

2. Click Check Out on the shortcut menu. Files available for check-out
have a green dot next to them. Files that are currently checked-out have
a red check next to them.

To check in a fileTo check in a file

1. In Page view, click Save  to save your changes.

2. In the Folder List in any view or in Folders view, right-click the file you
want to check in, and then click Check In on the shortcut menu.

To see the checkout status
of files, point to Reports on
the View menu, and then
click Checkout Status.

To see the checkout status
of files, point to Reports on
the View menu, and then
click Checkout Status.
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Managing large WebsManaging large Webs

In order to manage a large Web, you may want to control who can have access to
different sections of the Web. To easily set access control for viewing, editing, and
administrating permissions over any portion of a Web site, FrontPage 2000
introduces the ability to create Webs within Webs, called subwebs. You can also
create a nested subweb below another subweb. Nested subwebs allow you to have
control over site-wide management issues and allow groups of users to have access
to specific content. For example, in your school’s Web site, the students could have a
nested subweb they would own, then the newspaper staff could have a nested
subweb within the student subweb. This allows sites to grow larger yet at the same
time be more easily managed.

To create a nested subwebTo create a nested subweb

1. On the Views toolbar, click  to go to the Page view.

2. On the File menu, click New, and then Folder.

3. Name the new folder.

4. Click the folder you just created.

5.  In the Folder List, right-click the folder you want to convert to a web, and
then click Convert to WebConvert to Web  on the shortcut menu.

To change permissionsTo change permissions

In order to change the permissions on a subweb, you must have the
FrontPage Server Extensions installed on the Web server.

1. Select the subweb on which you want to change permissions.

2. On the Tools menu, click Security, and then Permissions.
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Selecting target browsersSelecting target browsers

Many of the exciting features discussed in the following chapters work only in the
latest browsers. FrontPage 2000 includes a tool that allows you to target your Web
for compatibility with specific browsers and technologies.

If you are creating an intranet and know that everyone visiting your Web site in your
school has the most current versions of Microsoft Internet Explorer, all of the
FrontPage 2000 features are available.

If you are creating a Web site for use on the internet, and you want visitors with older
browsers to see the same features that viewers with new browsers see, you need to
set the target browser for the older browsers. Commands not supported by those
browser technologies or versions are unavailable (that is, they appear dimmed) on
menus in FrontPage 2000 as you work.

• The following table lists the default technologies and features supported for
each browser compatibility combination. If you override the default and
enable a technology or feature not supported by a specific browser or
version, your pages might not be displayed properly, or they might contain
errors. A check indicates that the technology or feature is supported

Browser
ActiveX
controls

VB
Script

JavaScript
and

Java applets

Dynamic
HTML Frames CSS

1.0
CSS
2.0

Active
server
pages

 Internet Explorer
 4.0 and later �� �� �� �� �� �� �� ��

 Internet Explorer
 3.0 and later

�� �� �� �� �� �� ��

 Netscape Navigator
 4.0 and later �� �� �� �� �� ��

 Netscape Navigator
 3.0 and later

�� �� ��

 Internet Explorer
 and Navigator
 4.0 and later

�� �� �� �� �� ��

 Internet Explorer
 and Navigator
 3.0 and later

��

 Microsoft WebTV ��
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• If you choose Netscape Navigator only, Both Internet Explorer and
Netscape Navigator, or Microsoft Web TV in the Browsers box, the
following commands and settings are unavailable:

• Marquee

• Video

• Table background picture

• Cell borders and background

• If you choose Microsoft Internet Explorer, Both Internet Explorer and
Netscape Navigator, or Microsoft Web TV in the Browsers box, the Blink
check box setting is unavailable:

To target only selected browsersTo target only selected browsers

1. On the Tools menu, point to Page Options, and then click the
Compatibility tab.

2. In the Browser box, select the specific browsers you want.

3. In the Browser versions box, select the specific versions of browsers
that you want.

Tracking the progress of the Web siteTracking the progress of the Web site

You can create reports that:

• Indicate which pages in your Web take too long to download. FrontPage
2000 calculates the size of all pictures, text, controls, and other elements
linked to any page in your Web to show how long it takes for site visitors to
download that page at different modem speeds.

• Indicate which files in your Web aren't linked to any other files. You can use
this information during regular Web maintenance to delete any outdated or
duplicate files.

• Show and print site summaries. FrontPage2000  calculates the number and
sizes of pages, pictures, incomplete tasks, and other elements in your Web.
You can see which files are oldest or newest, group them by the person or
workgroup they're assigned to, sort them by size, and so on.

In Reports view, the Site Summary report lists the total number of hyperlinks in your
Web as well as the number of unverified links, broken links, external links, and
internal links.

Hyperlinks view shows you a graphical representation of the hyperlinks to and from
any file in your Web. FrontPage 2000 automatically tracks and repairs any internal
hyperlinks in your Web whenever you move, rename, or delete a file. You can
instantly check the status of any external hyperlinks using the Recalculate
Hyperlinks command on the Tools menu.

To target specific
technologies or features
instead of browsers, click
Custom, and then in the
Technologies area, select
or clear the check boxes of
the specific technologies or
features you want to
enable or disable.
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Extending your knowledgeExtending your knowledge

To give your site a professional look, you can choose from templates and themes to
design a Web in FrontPage 2000. You can look at different Web site templates to see
the types of pages included on the site. This may give you additional ideas about how
to use FrontPage 2000 in your classroom.

Design an intranet for your Web site. Intranets enable groups to share information
quickly and easily. An Intranet would be perfect for a school to share student work
and staff information. The Microsoft Office 2000 60 Minute Intranet Kit provides a
template that helps you set up an Intranet. To order the kit, go to the following Web
site:

http://www.microsoft.com/office/intranet

Also, you can order the FrontPage 2000 45-day Trial CD for $6.95. This is a bonus
pack CD with a FrontPage 2000 tutorial and hands-on exercises. The CD also has
additional themes and clip art. To order the CD, go to the following Web site:

http:www.microsoft.com/frontpage/trial

On the File menu, click
Import to import any site
you like in order to get
started quickly. Change the
graphics and text to match
your own.
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Adding ContentAdding Content
to a Web Siteto a Web Site

In the previous chapter, you planned and created your Web site. Next, you'll work on
the home page, which is what visitors usually see first when they come to your Web
site on the Web. Think of your home page as introduction to the rest of your site. Use
it as a guide to the types of information that viewers can find on the Web site, or a
table of contents.

You have also added a theme to your Web site, but because themes are predefined,
it may happen that your Web site looks like someone else’s. In this chapter, you learn
how to customize a theme to create a unique look for your site.

Before you beginBefore you begin

• You have already decided what type of information you want to have on your
Web site. Now you need to write the content text. You can write the text in
Microsoft Word and paste it into your Web pages, or you can write the
content directly in FrontPage 2000. You have access to most of the features
of Word, such as spell checking and thesaurus, even when working directly
in FrontPage 2000.

• Choose the content for your header, which is the first thing people see when
they visit your site on the Web. Most headers include the name of the
organization, a logo or graphic, and a tag line or short description of what
visitors should expect.

• Decide what information you want to include in your page footers.
Consistently placed elements in a footer can help unify a Web site's look, aid
site navigation, and let people know how to contact you. Information
commonly found in footers includes links to the home page, contact
information, copyright, and more.

What you will do:

4 Add content to
your home page.

4 Put together a
page header.

4 Add text to your
page.

4 Format text.

4 Create a bulleted
list.

4 Insert graphics,
pictures, and
buttons.

4 Customize your
site's look.
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Organizing the page headerOrganizing the page header

The header, located at the top of the page, contains the title of the Web page. It may
also contain banners and navigation buttons to other pages on the Web site. A good
header lets visitors know what page they are on and helps them get to the
information they are looking for.

To organize the home page headerTo organize the home page header

1. If your Central High School Web site is not open, open it and go to Page
view, and then double-click central_high_school_home_page.htm. The
Web page already has a banner in the header. It was added when you
applied a theme to your Web site.

2. Click to the right of the banner and press ENTER.

3. On the Insert menu, click Navigation Bar.

4. In the Navigation Bar properties dialog box, select the Child level
option. This adds navigation buttons on the home page that link to each
of the pages on the level below the home page.

5. In the Orientation and appearance area, select the Horizontal and
Buttons options, and then click OK.

To change shared borders on the home pageTo change shared borders on the home page

1. On the Format menu, click Shared Borders.

2. In the Shared Borders dialog box, select the Current page option, and
clear the Left option.

3. Click OK. This deletes the left shared border on the home page without
deleting the shared border from the other pages.
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Adding the body or active pageAdding the body or active page

The body of a Web page, otherwise known as the active page, is located below the
header and contains the content or information about the Web page. It may also
include images, text, sound clips, motion clips, and links to other pages.

Adding and formatting textAdding and formatting text

Adding text to a Web in FrontPage 2000 is very simple. You can type directly in
the FrontPage 2000 Web page, paste text from an program like Word 2000, or
you can import text from a file. After adding text to the active page, you can make
the text bold, italic, or underlined. You can also change the font, the font size, the
color, and much more. In addition to easily formatting text, you can also add
bullets and numbering to lists, and list indents.

To add text to a pageTo add text to a page

1. Click in the body of the home page after the “Welcome to the Central
High School Home Page!” text you typed earlier.

2. Press ENTER twice.

3. Type Visit Calendar of Events for the daily calendar, sports events,
upcoming music performances, and extracurricular activities and
programs.

4. On the Formatting toolbar, click the Left align  button.

5. Press ENTER, and type the following sentences:

• Visit Departments and Faculty to see department chairs, faculty
room numbers, phone extensions, and office hours.

• Visit Academic Requirements for core graduation requirements,
available electives, academic counseling information, and
counselor contact information.

• Visit Alumni Activities to find out what your graduating class has
planned for reunions, mentoring, and fund-raising.

• Visit Educational Links to see the most interesting and educational
sites our students and educators have found on the World Wide
Web.

You can also paste text from other word processing tools into your FrontPage
2000 Web page. Simply copy the text in the word processor, place the
pointer in the active page, and click Paste .
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To import text from another programTo import text from another program

1. Click in the body of the home page after “Welcome to the Central High
School Home Page!”

2. On the Import menu, click File. The Select File dialog box appears.

3. In the Files of type box, select the file type the text was saved in. For
example, if you saved the text in Microsoft Word 2000, select Word 97-
2000 (*.doc) as the file type.

4. Click the file, or find the file and then click it.

5. Click Open. The text appears in the active page.

To change font, font size, and font colorTo change font, font size, and font color

1. Select the “Visit Departments and Faculty …” sentence you typed in the
procedure above.

2. To change the font, from the Font drop-down list, select Comic Sans
MS.

Style drop-down list Font drop-down list Size drop-down list

3. To change the font size, from the Size drop-down list, select 2 (10 pt).

4. To change the font color, click the arrow to the right of the Font Color
button. The standard and theme colors appear, with more colors
available by clicking More colors.

5. To keep a consistent look and feel between pages on your Web site,
select a color from the Theme’s Colors area. The selected text changes
to the new color you chose.

Font Color button

Standard Colors buttons

Theme’s Colors buttons

HTML Hex values for the selected color

Office 2000 files can be
saved directly to a
FrontPage-based Web site.

To match a color to an
existing color anywhere on
your screen, select More
Colors and use the color
picker to “pick” the color
you want.
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To copy formattingTo copy formatting
1. Click anywhere in the sentence you just formatted.

2. Click the Format Painter  button.

3. Drag the pointer across the other “Visit…” sentences. The text formatting
changes to match the first sentence.

Adding bulleted listsAdding bulleted lists

Since information on a Web is most effective when it is presented briefly and
concisely, you may want to use lists to share concepts, items, or options. For
items that do not necessarily belong in a particular order use a bulleted list, or
unordered list. For procedures or other sequential lists, use a numbered list. The
procedure for adding lists to a page is simple. Note that a bulleted list created in
a shared border appears on all pages of your site.

To add a bulleted list to a page on your siteTo add a bulleted list to a page on your site
1. Select all of the “Visit…” sentences you typed in the previous steps.

2. On the Format toolbar, click the Bulleted List  button. Each of the
sentences now has a bullet in front of it, and a hanging indent.

3. To move the list to the right, click the Increase Indent  button.

You can create numbered lists the same way by clicking the Numbering 
button.

Adding graphicsAdding graphics

FrontPage 2000 includes a full library of clip art from the Microsoft Clip Gallery.
Spice up your Web site with buttons, icons, background patterns, video clips, and
other images from the Clip Gallery.

To add a graphicTo add a graphic
1. Click to the left of the Welcome text.

2. On the Standard toolbar, click the Center  button.

3. On the Insert menu, click Picture and then click Clipart.

4. In the Microsoft Clip Gallery dialog box, on the Clip Art tab, click
Academic, and then click the stacked books graphic.

5. Click the Insert Clip  button. The image appears on the Web page.

6. Click the graphic to select it.

7. Click the handle in the lower-right corner of the image, and drag it up
and to the left to resize the image to fit the space.

If you resize an image
making it smaller, use the
Resample button on the
Pictures toolbar.
Resampling the image
creates a smaller file,
decreasing the time it
takes to download the
page.
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To change the way text wraps around a graphicTo change the way text wraps around a graphic

1. Click anywhere on the graphic.

2. On the Format menu, click Position . The Position dialog box appears.

3. Under Wrapping Style, click Left.

4. Click OK. The text remains next to the graphic instead of wrapping below
the graphic.

Adding text to the footerAdding text to the footer

The footer, located at the bottom of the page, can contain navigational links to
other pages, a school district logo, or any contact information such as a phone
number or an e-mail address. If the footer is not part of the shared border, it
appears only on the page where you place it.

In this procedure, you add school contact information to the footer. This type of
information would probably be best used in a footer in a shared border. That
way, you can easily change the information in the footer once, and then it is
automatically updated on every other page where it appears.

To add text to the footerTo add text to the footer

1. Click at the end of the Central High School Home Page text in the
bottom shared border and press SHIFT+ENTER. Using the SHIFT key with
ENTER gives you single spacing instead of double spacing.

2. Type Telephone, and press TAB.

3. Type 123-555-0111, and press SHIFT+ENTER.

4. Type Fax, and press TAB until the insertion point is aligned below the
telephone number.

5. Type 123-555-0128, and press SHIFT+ENTER.

6. Select the text you just typed.

7. From the Font Size drop-down list, select 1 (8 pt). The contact
information appears in the shared border on each of the Web pages you
have created.
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Checking the spelling in your Web siteChecking the spelling in your Web site

Checking the spelling on your Web site helps you have a Web site that looks
professional and is error-free.

To checkTo check the spellingthe spelling

• New in FrontPage 2000 is background spell checking: simply right-click any
word with a red squiggly line under it and select the proper spelling.

-or-

• To check spelling throughout your web site:

1. On the Standard toolbar, click the Spelling  button.

2. In the Spelling dialog box, click Change for the correct spelling of any
misspelled words.

3. Click OK to close the Editor.

Time-stamping a pageTime-stamping a page

A timestamp shows when a page was last edited or updated. Timestamps allow
people to see how current the information is on a Web and whether the
information has changed since the last time they visited.

To time-stamp a pageTo time-stamp a page

1. Click after the phone numbers in the footer and press ENTER to insert
the timestamp in the footer.

2. On the Insert menu, click Date and Time. The Date and Time dialog box
appears.

3. Select the Date this page was last edited option.

4. Select a date format from the Date Format drop-down list.

5. Select a time format from the Time Format drop-down list (optional).
You may select a date format, a time format, or both.

6. Click OK.
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Customizing the look of your WebCustomizing the look of your Web

Now that you have already chosen a theme, you can customize it so that it suites
your needs. You can modify the graphics used in the theme, the fonts, page
backgrounds, and layout. Notice that when you change the color scheme, the text
colors also change.

To change the color schemeTo change the color scheme

1. On the Format menu, click Theme.

2. Click Modify. A new set of buttons appears at the bottom of the Themes
dialog box.

3. Click Colors. FrontPage 2000 includes professionally designed color
schemes to choose from, or you can create your own color scheme.

4. On the Color Schemes tab, select a new color scheme. A preview of the
change appears in the Sample of Theme area.

5. To save the change to your theme, click OK.

6. Select the All pages option, and then click OK again. A dialog box
appears asking if you want to save the theme.

7. Click Yes to save the theme, type a name in the Save Theme dialog box,
and then click OK.

To change text stylesTo change text styles

1. On the Format menu, click Theme.

2. Click Modify. Another set of buttons appears at the bottom of the
Themes dialog box.

3. Click Text. The Modify Theme dialog box appears.

4. To change the font for the headings, select Heading 1 from the Item
drop-down list and then select a new font from the Font list.

5. Continue to change fonts for any other styles in the Item drop-down list.
A preview of the changes appears in the Sample of Theme area.

6. To save the change to your theme, click OK.

7. Select the All pages option, and then click OK again. A dialog box
appears asking if you want to save the theme.

8. Click Yes to save the theme, type a name in the Save Theme dialog box,
and then click OK.
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Extending your knowledgeExtending your knowledge

To give your site a professional and consistent look, use styles. Styles define the
appearance of text elements of a Web, such as headings and text, and can make
formatting simple. When you apply a style to a paragraph or word, you can apply a
whole group of character or paragraph formats in one simple operation. When you
want to change the formatting of all the text of a particular element at once, just
change the style that's applied to that element.

You can create a new style and add it to the standard HTML styles listed in the Style
box on the Formatting toolbar. Any authors editing that page can then apply the new
style to anything on the page, including text, paragraphs, pictures, and tables. The
new style can also be applied to a page element in combination with any standard
HTML style, resulting in a combination of the two styles.

For example, if you create a style called redbg that specifies a red background
behind a page element, it's listed in the Style box as .redbg. When you apply .redbg,
the background of the selected page element turns red. If you apply a standard HTML
style such as Heading 1 to the same page element, then the page element inherits
the styles of both Heading 1 and .redbg, indicated in the Style box as Heading.redbg.

Creating styles for a Web siteCreating styles for a Web site
Styles created for one page can't be shared with other pages. However, it’s just
as easy to make styles for a whole Web by using an external style sheet. Style
Sheets are documents that control formatting. Like themes, a style sheet can
help you unify the look of your Web or change the look quickly.

If a style feature is unavailable (that is, it appears dimmed on the menu), or if
you do not want to use cascading style sheets in order to ensure compatibility
with older browsers, you need to enable or disable specific versions of CSS using
the Compatibility options found in Page Options on the Tools menu before
creating your style sheet.

To create a style for a pageTo create a style for a page
1. In Page view on the Normal tab, on the Format menu, click Style.

2. Click New, and then in the Name box, type the name of the new style.

3. Click the Format button, and then specify the formatting characteristics
for the new style:

4. To set font properties, such as the font family or color, or character
spacing, click Font.

5. To set alignment, indentation, and spacing, click Paragraph.

6. To set borders and shading, click Border.

7. To set the style of bullets and numbering, click Numbering.

8. To set positioning properties, such as the wrapping style or location,
click Position .
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Creating or editing an embedded style sheetCreating or editing an embedded style sheet

An embedded style sheet is a type of cascading style sheet that's "embedded"
within the HTML <HEAD> tags of a page. Styles in an embedded style sheet can
be used only on that same page.

When you create or modify a style for a page using the Style command on the
Format menu, FrontPage 2000 automatically creates an embedded style sheet
(if it doesn't already exist), and saves the style as a class selector within the
embedded style sheet.

You can edit the styles in the embedded style sheet using the Style command on
the Format menu.

If a style feature is unavailable (that is, it appears dimmed on the menu), or if
you do not want to use cascading style sheets in order to ensure compatibility
with older browsers, you need to enable or disable specific versions of CSS using
the Compatibility options found in Page Options on the Tools menu before
creating your style sheet.
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Connecting PagesConnecting Pages

Now that you have added the Web pages and content to your Web site, you can
create hyperlinks between pages and to other Web sites on the World Wide Web.

Like the term “World Wide Web” suggests, the Internet is made up of an enormous
numbers of linked computers, Web sites, documents, images, and text. Hyperlinks
are what make up the strands of the web. When you link your site to the World Wide
Web, your site becomes part of a huge network of information and with FrontPage
2000, becoming a part of the World Wide Web is simple.

Before you beginBefore you begin

• Use your outline to determine which of your pages to link together.

• Decide on an e-mail address to use as a point of contact for people who wish
to correspond with someone involved with the Web site.

• Make a list of sites outside of your own Web site that you want to create
links to. Later in this chapter you learn how to create links to those site, so
you may want to copy down the web address names. It is important to make
sure that you record the exact web address, or links you create may not
work.

What you will do:

4 Create hyperlinks
within your Web
site.

4 Create text
hyperlinks to
sites on the
World Wide Web.

4 Create an image
map.

4 Use hyperlinks to
receive e-mail.

4 Remove
hyperlinks.

4 Check the
hyperlinks in the
Hyperlinks view.

4 Preview your Web
in the browser.

4 Create a
hyperlink to an
Office document.
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Creating hyperlinksCreating hyperlinks

Hyperlinks connect locations on the World Wide Web, such as Web pages, different
sites, or just paragraphs located on the same page. Hyperlink destinations can be
text, graphics, e-mail addresses, files (such as a multimedia file or Microsoft Office
document), or programs. A hyperlink can be text or a picture.

Images containing hyperlinks are known as image maps. A well-designed image map
gives users visual cues about where each hyperlink takes them. For example, an
image map for a tourism bureau could be an actual map of a geographical region.
Clicking on a city in the map could take you to tourist information about the city.

On your Web you can include links to other sites that visitors to your site might want
to check out. On your Educational Links page, you could list your favorite links to the
World Wide Web. This provides an easy way to get to your favorite and most often
used Web sites on the World Wide Web.

When you type a hyperlink in Page view, FrontPage 2000 automatically formatts the
link. The text and a line below it appear in blue and, with an active Internet
connection, a link occurs when you click.

Understanding the URLUnderstanding the URL

The destination of a hyperlink is encoded as a URL, or Uniform Resource
Locators. URLs, also known as web addresses, contain information about web
servers or network location, path, and file name.

http://www.microsoft.com/frontpage/productinfo/default.htm

Protocol Web server or network location
Also called a domain

Path File name

Hyperlinks are made up of URLs that are either absolute or relative:

• An absolute URL contains the full address and is generally used for
linking different sites.

• A relative URL has one or more missing parts and is generally used for
linking within a particular site. If the protocol and domain are missing,
the Web browser uses the protocol and domain of the current page.

When you create hyperlinks in FrontPage 2000, you do not need to know the
destination URL. You can browse to the page, or file whether on the World Wide
Web or a system you and your site visitors can access, and FrontPage 2000
provides the correct URL. For hyperlinks to destinations in the Web you are
working on, FrontPage 2000 creates relative URLs. If you rename or move a file
in your Web, FrontPage 2000 updates all the URLs that point to the file. By
generating relative URLs, FrontPage 2000 saves you time and ensures that your
Web site is portable.
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Creating a hyperlink to a page or file in a Creating a hyperlink to a page or file in a WebWeb

Creating hyperlinks with FrontPage 2000 is easy. You can use the Create
Hyperlink dialog or drag and drop to create a hyperlink to a destination such as a
page or file in a Web. You can create hyperlinks from your home page to the
other pages in the Web or create a hyperlink to a GIF picture. In this activity, you
create hyperlinks to favorite Web sites from the Educational Links page

To create a hyperlink within your Web siteTo create a hyperlink within your Web site

1. If your Central High School Web site is not open, open it and go to Page
view, and then double-click central_high_school_home_page.htm. Each
of the bulleted items has the title of a Web page already in the text.

2. Select Calendar of Events in the first bulleted item to link to the
Calendar of Events page in you Web site.

3. Click the Hyperlink  button.

4. Click calendar_of_events.htm in the Create Hyperlink dialog box and
then click OK. The text changes color and now has an underline
indicating that it is a hyperlink.

To create a hyperlink to the World Wide WebTo create a hyperlink to the World Wide Web

1. In Page view, double-click educational_links.htm.

2. Type the text you want to use as a hyperlink and then select it. For
example, type and select "Encarta Schoolhouse."

3. Click the Hyperlink  button.

4. Type the URL in the URL area and click OK.
-Or-
Click the World Wide Web  button. In your Web browser, browse to
the page that you want, and then press ALT+TAB to switch back to
FrontPage 2000. The location of the page you visited is displayed in the
URL box.

If the destination page or
file is in the current web,
click the page or file in the
Folder List, and then drag it
to the open page where you
want to place the hyperlink.

If you want to have the URL
on the page, you can create
a hyperlink by simply typing
the full URL and pressing
RETURN. FrontPage 2000
automatically creates a
hyperlink to the URL you
typed. For example, for the
Encarta Schoolhouse
hyperlink, simply type
http://encarta.msn.com/
schoolhouse/default.asp
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Creating a bookmarkCreating a bookmark

A bookmark, also known as an anchor, is a location or text on a page marked as
a destination for a hyperlink. If a Web page is long and divided into sections, a
bookmark allows you to link to a section of the page rather than to the top of the
page as with conventional hyperlinks. To display the section of a page to the site
visitor, insert a bookmark at the beginning of the section, and then create a
hyperlink with the bookmark as its destination. When the site visitor clicks the
hyperlink, the relevant part of the page is displayed, rather than the top of the
page.

If a location is bookmarked, you see a blue flag  when looking at your Web
page in Page view with the Normal tab selected. The flag is simply a reminder to
you of the bookmark’s location. It is not visible when viewing the Web page in the
browser. If text is bookmarked, the text is displayed in Page view with a dashed
underline when the Normal tab is selected.

To create a bookmarkTo create a bookmark

1. In Page view, position the insertion point where you want to create a
bookmark, or select the text to which you want to assign the bookmark.

2. On the Insert menu, click Bookmark.

3. In the Bookmark name box, type the name of the bookmark (spaces are
allowed).

Create a hyperlink to a bookmarkCreate a hyperlink to a bookmark

1. In Page view, type the text you want to use as a hyperlink, and then
select it.
-or-
If you want to use the name of a bookmark as the hyperlink text,
position the insertion point where you want to insert the hyperlink.

2. Click the Hyperlink  button.

3. Select the page that contains the bookmark.

4. In the Bookmark box, click the bookmark you want to use as the
destination.
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Adding linked graphics to a WebAdding linked graphics to a Web

Just as you can use pictures and images to make your Web more visually
appealing, you can also to create links using graphics rather than ordinary test.
When you insert graphics, it is a good idea to also add ALT text, which creates a
description of the graphic that visitors see when they hover a cursor over the
graphic. ALT text is helpful when visitor with disabilities cannot see the graphic or
it the graphic is not available for viewing.

To insert an imageTo insert an image

1. On the Educational Links page, place the cursor to the left of the
Encarta Schoolhouse link.

2. On the Insert menu, point to Picture, and then click Clipart. The Clip Art
Gallery dialog box appears.

3. On the Pictures tab, scroll down and click Buttons & Icons.

4. Click the button graphic you prefer, and then click the Insert clip button.

To add ALT text to a graphicTo add ALT text to a graphic

1. Right-click the image you just inserted.

2. Click Picture Properties, and then click the General tab.

3. Under Alternative representations in the Text box, type the text that
you want to appear in the event that the graphic is not available to the
person viewing your Web page. For example, type This button is a link to
Encarta on the Encarta link button.

4. Click OK.

To create a hyperlink from a graphicTo create a hyperlink from a graphic

1. Click the image you just inserted.

2. On the Standard toolbar, click the Hyperlink  button. The Create
Hyperlink dialog box appears.

3. In the Create Hyperlink dialog box, type the Encarta Schoolhouse URL in
the URL box.

4. Click OK. The button is now a hyperlink.
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Creating image mapsCreating image maps

Image maps are graphics that contain multiple hyperlinks. FrontPage 2000
allows you to create image maps by inserting the image on the page and using
the tools on the Image toolbar to create several hotspots that include hyperlinks.
A hotspot is an area on a graphic that links to another page or Web site.
Generally, hotspots are simply an area on a graphic, but you can also add text to
the hotspot.

To insert an imageTo insert an image

1. On the Educational Links page, place the cursor to the right of the
Encarta Schoolhouse link and press ENTER.

2. On the Insert menu, point to Picture, and then click Clipart. The Clip Art
Gallery dialog box appears.

3. In the Search for clips box, type world.

4. Click the globe graphic, and then click the Insert clip button.

5. Add ALT text to the graphic.

To create a hotspotTo create a hotspot

1. On the View menu, point to Toolbars, and then click Pictures.

2. On the Pictures toolbar, click the Rectangular Hotspot  button. The
mouse pointer becomes a pencil.

3. With the pencil, draw a rectangle around North America to create a
hotspot. The Create Hyperlink dialog box appears.

4. In the URL box, type http://encarta.msn.com/evg/default.shtm, the URL
for the Encarta Virtual Globe.

5. Click OK. The area is now a hyperlink.

To create a text hotspotTo create a text hotspot

1. On the Pictures toolbar, click the Text  button.

2. In the text box that appears, type Xpeditions.

3. Move the text box to the location you want by clicking and dragging the
text box border.

4. Double-click the border of the text box. The Create Hyperlink dialog box
appears.

5. In the URL box, type http://www.nationalgeographic.com/xpeditions/
main.html?main=hall, the National Geographic Expeditions URL and
then click OK.
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Adding anAdding an e-mail hyperlink e-mail hyperlink

In addition to conventional hyperlinks, you can also add links to e-mail. You can
create a hyperlink that opens and addresses an e-mail message to the address you
specify. This allows visitors to your Web site to send you comments.

To add an e-mail linkTo add an e-mail link

1. Go to the Central High School Home Page in Page view.

2. Position the pointer after the fax number in the bottom shared border,
and press ENTER.

3. On the Standard toolbar, click Hyperlink .

4. In the Create Hyperlink dialog box, click Make a hyperlink that sends

E-mail . The Create E-mail Hyperlink dialog box appears.

5. In the Type an E-mail address text box, type the address you want
comments to be sent to, and click OK.

6. In the Create Hyperlink dialog box, click OK.

Removing hyperlinksRemoving hyperlinks

At some point, you may decide you want to remove a link if your Web changes or if
the link no longer works because someone else’s site has changed. Deleting a
hyperlink from a page is simple.

To remove a hyperlink from your WebTo remove a hyperlink from your Web

1. In Page view, select a hyperlink on one of the pages in your Web site.

2. Do one of the following:

• To delete the hyperlink completely, including the hyperlink text,
press DELETE.

• To preserve the hyperlink text but delete the hyperlink associated
with it, select the hyperlink, and then click Hyperlink  button.
Select the contents of the URL box, and then press DELETE.

Not all Web browsers
support hyperlinks to e-mail
addresses.
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Managing hyperlinks on your Web siteManaging hyperlinks on your Web site

With FrontPage 2000, you can check your Web has incorrect or broken hyperlinks
and quickly, repair them. A broken hyperlink is one that has an invalid destination
URL and returns an error if the site visitor clicks the hyperlink.

Verifying hyperlinksVerifying hyperlinks
A critical part of managing a Web site is verifying that the hyperlinks go to the
correct external destinations (destinations that are outside of your Web). After
hyperlinks have been verified, their status does not change until you verify the
hyperlinks again, or close and reopen the Web.

To verify your hyperlinksTo verify your hyperlinks

1. In Reports view, click the Verify Hyperlinks  button on the Reports
toolbar.

2. Select the Verify all hyperlinks option, and then click Start. The status
of all hyperlinks in the current Web appears.

Repairing broken hyperlinksRepairing broken hyperlinks
A hyperlink might have an invalid URL for various reasons; you may have
mistyped it, or, if the destination page is on another World Wide Web site, the
page might have been changed or removed.

To repair a hyperlinkTo repair a hyperlink
1. On the View menu, point to Reports, and then click Broken Hyperlinks.

2. All broken hyperlinks in your Web are listed. If a hyperlink's destination
is not in the current Web, the status of the hyperlink is Unknown.

3. Double-click a hyperlink with Broken status.

4. To display the page to edit it, click Edit Page.

5. If you know the correct URL of the destination, edit it in the Replace
hyperlink with box.
-or-
Click Browse to browse to the page or file in a Web, file system, or World
Wide Web.

6. To repair other occurrences of this hyperlink in all pages in the current
Web, click Change in all pages.
-or-
To repair other occurrences of this hyperlink in selected pages, click
Change in selected pages, and then select the pages.

7. Click Replace. If the hyperlink's destination is not in the current Web,
the status of the hyperlink changes to Unknown. If the destination is
valid, the hyperlink no longer appears in the Broken Hyperlinks report.

In order to verify all of your
hyperlinks, save all open
pages.
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Previewing your Web in the browserPreviewing your Web in the browser

After creating your hyperlinks, you should test each link. You can do this by
previewing your Web with your browser. . (A browser is software that displays Web
pages.) When your Web site is open in the browser, click each link to make sure it
works properly. Use the Back button to return to your own Web site. FrontPage 2000
includes Microsoft Internet Explorer 5.0, a popular Web browser You can use Internet
Explorer 5.0 to review pages you have created, to check hyperlinks, and to explore
the World Wide Web.

To preview your Web using Internet Explorer 5.0To preview your Web using Internet Explorer 5.0

Simply click the Preview tab.

To preview your Web using other browsersTo preview your Web using other browsers

1. On the File menu, click Preview in Browser.

2. In the Preview Browser dialog box, select the browser you wish to use,
and click Preview. The browser opens to your Web site.

3. Click some of the links you made in this chapter and look at the work
you have done.

4. On the File menu, click Close when you are finished previewing.
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Extending your knowledgeExtending your knowledge

In addition to adding hyperlinks to text, graphics, pages, and sites, FrontPage 2000
lets you create links to Microsoft Office documents. This is especially helpful if your
Web site is on an intranet and you want other educators to have access to Microsoft
Office documents.

Creating hyperlinks on your Web for Office documentsCreating hyperlinks on your Web for Office documents

With FrontPage 2000, you can quickly and easily create hyperlinks to Office
documents, such as documents created in Word or Excel. When a visitor to your
Web site clicks a hyperlink to an Office document, the document opens. Some
Web browsers display the document inside the browser window; other browsers
open a separate window.

To create a hyperlink to an Office documentTo create a hyperlink to an Office document

1. In Page view, type the text you want to use as a hyperlink and then
select it. For example, type and select "Budget Spreadsheet."

2. Click the Hyperlink  button.

3. Do one of the following:

• If the Office document is in the current Web, navigate to the Web in
which the document is located, and then select the document.

• If the Office document is on the local file system and you have
access permission to the file, click the File button, browse to the
document, and then select it.

• Import the file into your Web site.

4. Click OK. The text you selected is now a link to the document.

If the Office document is in
the current web, click it in
the Folder List, and then
drag it to the open page
where you want to place
the hyperlink.
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Adding FeaturesAdding Features
to your Webto your Web

Now that you’ve finished creating your Web site, you’re ready to publish it. Before you
do though, considering adding some extra flare and character to your Web. You can
add animation effects, set up tables, forms, and frames, create buttons that change
when you move your mouse pointer over them, insert video clips, and more. Adding
these features to your Web without FrontPage 2000 would normally mean that you
would need to know a lot of complex code, but FrontPage 2000 does all the work for
you.

Before you beginBefore you begin

• Look over your Web pages and decide which headings could benefit from an
animation effect. You can make your text slide, bounce, or spiral onto the
page. You can also pick the timing for the effects: when the page finishes
loading, when you mouse-over the text, and when you click text.

• Determine what types of information would be best placed in a table.
Examples include faculty schedules, athletic schedules listed by sport,
calling trees, and room assignments.

• Brainstorm about the information you may want to collect from alumni. This
can include name, address, and job status.

What you will do:

4 Add animation
effects to your
Web.

4 Use a table to
improve you
display
information.

4 Add a survey to
your Web.

4 Create a hover
button.

4 Host interactive
discussions on
your Web.

4 Create a hit
counter.

4 Learn about and
create a frame
for your page.
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Adding animation effectsAdding animation effects

With FrontPage 2000, it’s easy to add animation effects to create movement and
interest to a Web page. Please note that because people use all kinds of browsers to
access the World Wide Web, animation effects created with DHTML code cannot be
seen by everyone who may visit your site. In order for the animation to work the way
you expect it to, visitors must view the animation with Internet Explorer 4.0 or later or
with Netscape 4.0 or later. When browsers don’t support DHTML, text appears just as
it did before you added the effect.

You may also want to look at FrontPage 2000’s new feature that lets you know
whether or not an effect is compatible with a particular browser—especially if you
want viewers with older browsers to see the effects included on your Web site. See
the Selecting target browsers section in the Designing a Web Site chapter of this
book for more information.

To add DHTML animation to a headingTo add DHTML animation to a heading

1. On the Views toolbar, click Page.

2. Double-click central_high_school_home_page.htm.

3. On the Format menu, click Dynamic HTML effects. The DHTML Effects
toolbar appears.

4. Select the heading “Welcome to the Central High School Home Page!”

5. In the On box, select Page load, so that visitors to your site see the
effect as the page loads in their browser.

6. In the Apply box, select Elastic. The heading stretches like elastic as the
page loads.

7. To see the effect, on the File menu click Preview in Browser. If you are
prompted, save your work. You see the effect as your browser loads the
page.

Creating a tableCreating a table

On Web pages, information often appears in tables with invisible borders. Tables help
you control your page layout so that everything is easy to find and to read. Tables
display information in a side-by-side format, in rows and columns. Each block of
information is called a cell, which can contain text, images, lists, and even other
tables. Choose from one of FrontPage 2000’s multiple templates for tables the table
that suits your needs.

In FrontPage 2000, tables are simple to create. In fact, you can set up tables with
FrontPage 2000 in much the same way you can in Microsoft Word. In the following
procedure, you create a table to organize teacher phone extensions, room numbers,
and classes taught.

To highlight the text that
will be animated, click the
Highlight DHTML Highlight DHTML EffectsEffects

button in the DHTMLDHTML
EffectsEffects toolbar. Place your
cursor over the highlighted
text to view a description of
the effect.
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To set up a tableTo set up a table

1. On the Views toolbar, click Page.

2. Double-click departments_and_faculty.htm.

3. Position the mouse pointer where you want to insert the table on the
page.

4. Click the Table  button.

5. Drag the cursor over the three columns and five rows. To expand the
number of columns or rows available in the box, click and drag the
cursor while highlighting the appropriate number of cells. The table
appears in your Web page.

6. Enter the following information in the table.

Name
Phone
Extension #

Room
Number

Browne, Kevin 2377 102

Cole, Sean 2358 120

Martin, Nina 2398 110

Wheeler, Wendy 2367 109

To create new table cellsTo create new table cells

1. On the View menu, click Table Toolbar.

2. On the Table toolbar, click the Draw Table  button. The mouse
pointer becomes a pencil.

3. With the pencil, in the top right cell, draw a vertical line from the right of
Room Number down through the bottom cell, so that you "cut" the
column in half.

4. On the Table toolbar, click the Draw Table button to de-select the pencil.

5. Place the mouse pointer on the line between the Phone Extension # and
Room Number columns.

6. When the double-arrow appears, click and drag the column border to the
left.

7. Using the double-arrow, resize all the columns to make them equal.

8. In the first cell of the new column, type Subject Taught.

9. In the cells beneath “Subject Taught”, type Chemistry, Computer
Science, Science, and Math.
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Adding interactivity to a Web with formsAdding interactivity to a Web with forms

With FrontPage 2000, you can use forms for visitors to you Web site to fill out. With
the forms, you can gather all kinds of information. Set up forms for alumni polls,
faculty surveys, and student research projects. Forms can contain text, tables,
images, and fields that visitors fill out and send to you. You can also easily customize
a form by adding bulleted lists, pop-up menus, buttons, check boxes, labels, and
places for visitors to enter text. In the following lessons, you create a form that uses
buttons and text areas. After collecting the information, you can then send it to a
database and publish the database on another Web page.

To format a form titleTo format a form title

1. On the Views toolbar, click Page.

2. Double-click alumni_activities.htm.

3. Type Alumni Information on the first line, and select it.

4. On the Format toolbar, click the Bold  button.

5. Change the font size from Normal to 16 pt.

6. On the Format toolbar, click the Center  button.

7. Click below Alumni Survey, and press ENTER.

8. On the Format toolbar, click the Align Left  button.

To create radio buttonsTo create radio buttons

Radio buttons require you to select one option from the button choices.

1. On the Insert menu, click Forms, and then click Radio Button.

2. Click in front of the radio button you just inserted, and press ENTER to
move the button down so you can type above the radio button.

3. Press the UP ARROW key, and type Did you graduate from Central High?

4. Click between the radio button and the Submit button, and press
ENTER.

5. Click after the radio button, and type Yes.

6. Press TAB several times. Follow step 1 to insert another radio button.

7. Type No after the button, and press ENTER.
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To create check boxesTo create check boxes

Check boxes allow you to select several options.

1. Type If yes, what year(s) did you attend Central High School?, and press
ENTER.

2. On the Insert menu, click Forms, and then click Check Box.

3. Place the cursor after the check box, type 1968, and press TAB.

4. Repeat steps 2 and 3 to insert check boxes for subsequent years.

5. Press ENTER.

To create one-line text boxesTo create one-line text boxes

A one-line text box limits the amount of text you can type in the box.

1. Place the cursor on a blank line below the check boxes. Type First
Name.

2. On the Insert menu, click Forms, and then click One-Line Text Box.

3. Press TAB twice, type Last Name: and then repeat step 2 to add another
one-line text box, press ENTER.

To create a scrolling text boxTo create a scrolling text box

A scrolling text box does not limit the amount of text you can type in the box.

1. Place the cursor below the one-line text box, and type Comments:.

2. On the Insert menu, click Forms, and then click Scrolling Text Box.

3. Click the scrolling text box and drag the handles to resize the text box to
the size you would like. Although the box is a particular size on screen,
this does not limit the amount of text someone can type in the box.

4. Save your page and click the Preview tab to see what it looks like in a
browser.

You must publish your Web site before data can be submitted from your form. To find
out more about publishing your Web site, see the Publishing a Web Site chapter in
this book.
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Using form results with a databaseUsing form results with a database

After you collect information from the alumni, you can save the information on a
database and publish the database information on your Web. In this section you
learn to send the data from the form to a Microsoft Access database, and then
show the contents of the database on a Web page.

The database integration features require you to host your pages on a server
with Active Server Pages (ASP) capabilities, such as Microsoft Internet
Information Server. You can use these capabilities with any ODBC-compliant
database. In this exercise, it is assumed that you have an ASP-capable server. If
you are not, you can author on your hard drive or a network drive, and later
publish to your ASP-capable Web server.

To save form results in a databaseTo save form results in a database

1. Return to Page view.

2. Right-click the radio button with yes next to it, and then click Form
Properties.

3. Select the Send to Database option, and then click the Options button.

4. Click Create Database. FrontPage 2000 automatically creates the
Access database file and places it in the newly created directory in your
Web. Since the page is called Alumni.htm, the database connection will
also be called Alumni.

5. In the dialog that appears, click OK to confirm that the database has
been created. The Options for Saving Results to Database dialog box
appears.

6. Click OK, and then click OK again in the Form Properties dialog box.
Another dialog box appears warning you that the page should be saved
as ASP.

7. Click OK again.

To save the pageTo save the page

1. On the File menu, click Save As, and then click OK.

2. In the File Name box, type Alumni, and in the Save As Type box, select
Active Server Pages, and then click Save.
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To create a page the shows data from the databaseTo create a page the shows data from the database

1. Go to Page view and click the New Page  button.

2. On the Insert menu, click Database, and then click Results.

3. Select the Use an Existing Database Connection option, select Alumni,
and then click Next.

4. Continue to click Next in the following dialogs, and then click Finish.

5. Save the page as results.asp.

Adding hover buttonsAdding hover buttons

Hover buttons are like other buttons that contain hyperlinks to other pages or files,
making Webs more fun to visit. When you hover your mouse pointer over a hover
button, it can glow, display a custom picture, or play a sound effect.

To add a hover buttonTo add a hover button

1. In Page view, double-click on alumni_activities.htm.

2. In the bottom-shared border, select the link text, Central High School
Home Page.

3. Click the Insert Component  button, and then click Hover Button.

4. In the Button text box, type Central High School Home Page as the label
for the hover button.

5. In the Link to box, type central_high_school_home_page.htm.

6. In the Button color box select a theme color.

7. In the Effect color box select a theme color that compliments the button
color you have chosen.

8. In the Effect box, select Glow.



In and Out of the Classroom with FrontPage 2000 Adding Features to your Web  59

9. Click OK.

10. Resize the button by clicking and dragging the handles until it is the
appropriate size.

11. To view this effect, save your file and click the Preview tab.

Extending your knowledgeExtending your knowledge

You can make your Web site even more useful and fun by adding discussion webs,
frames, and hit counters. With discussion webs, you can allow people to participate
in on-line discussions through your Web site. Use the discussion webs feature to
promote online study groups, parenting forums, or parent/teacher communications.
With frames, you can have greater control over how people navigate through your
site. FrontPage 2000 provides you with several templates to make building frames
simple. And if you’ve ever wondered just how many people visit or “hit” your site each
day, FrontPage 2000 can help. You can add a hit counter anywhere on your.

Exploring discussion WebsExploring discussion Webs

Discussion webs are interactive webs that let site visitors discuss topics by
reading articles or messages that have been posted, replying to articles, and
posting new ones. For example, your Web site may have a discussion group for
students to create an on-line study group, or there may be an area for teachers
and parents to discuss class assignments and homework tips. Create a
discussion web by using the Discussion Web Wizard. The wizard asks for the
features you want to use, then creates a Web and sets up the pages for you.
After you create the Web, you can open the pages and customize them.

To create a discussion WebTo create a discussion Web
1. On the File menu, point to New, and then click Web.

2. On the Web Site tab, click Discussion Web Wizard. Check the Add to
current Web check box, and then click OK.

3. Once the Discussion Web Wizard opens, follow the on-screen directions
to create a discussion group. Accept the wizard’s default settings, except
for the following:

• In Enter a descriptive title for this discussion, type Parent and
Faculty Discussion Group, and then click OK.

• In the Do you want the Table of Contents for this discussion to be
the home page for this web? box, select No.

• In the Frame options box, select the Dual interface option. This
allows the server to adjust the discussion page based on whether or
not the viewer’s browser can see frames.

4. Click Finish to generate your discussion Web. This creates several new
HTML pages in your folder. The main page of the discussion Web is
named disc1_frm.htm, which is where you want to direct hyperlinks.

Selecting the Dual interfaceDual interface
option allows users with
browsers that don’t see
frames to view your pages.
This is especially helpful for
those people using
browsers with screen
reading capabilities.
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5. After the wizard has set up your Web pages, modify them as you would
any other Web page.

6. To preview the discussion web, double-click disc1_frm.htm. You must
publish your Web site before you can have a fully functional discussion
Web. To find out more about publishing your site, review the Publishing
a Web Site chapter in this book.

Creating and adding a hit counterCreating and adding a hit counter

A hit counter tallies and displays the number of times a page has been visited. To
see how many people have visited your Web site, you can add a hit counter. For
example, add a hit counter to your alumni page so that you and site visitors can
see how many times the alumni page has been visited.

To install a hit counterTo install a hit counter

1. On the Views toolbar, click Page.

2. Double-click alumni_activities.htm and place the pointer at the bottom
of the page above the shared border.

3. Click the Insert Components  button, and then click Hit Counter.

4. In the Hit Counter Properties dialog box, select a counter.

5. Select Reset counter to, and type 0 in the text box.

6. Select Fixed number of digits, type 5 in the text box, and click OK.

7. Click the Save  button. You must publish your Web site before you
preview the hit counter.

Working with framesWorking with frames

Frames determine how Web pages are displayed in the browser window. Frames,
which divide the Web browser window into different areas, can retrieve and display a
separate page in your Web. You control the display of the page in a frame by creating
a hyperlink to the page and specifying the frame as the target of the hyperlink.

FrontPage 2000 has a set of templates for creating Frames pages. These allow you
to place many frames in a frame layout document. A simple frames page has two
frames, one containing hyperlinks, and the other displaying the pages that the
hyperlinks point to. In other words, when a visitor clicks a hyperlink in the first frame,
the page the hyperlink points to is displayed in the second frame.
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To add frames to a pageTo add frames to a page

1. On the File menu, click New and then click Page.

2. In the New dialog box, click the Frames Pages tab and select the
template Contents.

3. Click OK.

4. Click inside the left frame to select it, then click New Page.

5. At the top of the left frame type Alumni Directory, highlight the text, and
then select Heading 2 from the Style drop-down list.

6. Below the heading, type 1968 and press ENTER, 1969 and press
ENTER, 1970 and press ENTER, 1971 and press ENTER, and type
Alumni Survey.

7. Click inside the right frame to select it, then click New Page.

8. Type Welcome to Central High School's Alumni Directory, highlight the
text, select Heading 2 from the Style drop-down list, and then Press
ENTER.

9. Type, Former Central High School students have provided the
information presented in the directory. If you would like to submit
alumni information, please fill out the alumni survey.

When you click a template,
FrontPage 2000 displays a
thumbnail showing that
template's frames layout in
the Preview area.

Left Frame Right Frame
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To save a frames pageTo save a frames page

The page you just created actually consists of three individual HTML pages.
When saving a new frames page, you are prompted to save all three.

1. Click the Save  button.

2. In the File Name box, type alumni_directory.htm.

 

3. Click Save. The Save dialog box remains on-screen and you are
prompted to save the two remaining documents.

4. In the File Name box, type year_of_attendance.htm.

5. Click Save.

6. In the File Name box, type directory_main_page.htm.

7. Click Save.

To create a link on a frames pageTo create a link on a frames page

1. In the left-hand frame, select the text “Alumni Survey.”

2. Click the Insert Hyperlink  button.

3. In the Edit Hyperlink dialog box, select alumni_activities.htm.

4. Click OK.

1. Test the link by previewing this page. When you click on the hyperlink,
the new page should load in the right frame, and the left frame should
remain the same.

This blue border
indicates that
you are saving
the frame
definition page.

This blue section
indicates that
you are saving
the HTML page
in the left frame.

This blue section
indicates that
you are saving
the HTML page
in the right
frame.
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Publishing a Web SitePublishing a Web Site

Now that you’ve created your Web site in a "staging" area (a place where others
cannot find or view the pages), your Web site is ready to publish on the World Wide
Web or on an intranet. Publishing a Web generally means copying the files that make
up a Web site to a particular destination, such as a server. Use the publishing feature
in FrontPage 2000 to copy the Web site to your Internet service provider's (ISP)
server or to your district or school intranet server.

Before you beginBefore you begin

• Check the spelling on each Web page in your Web site. For information on
checking the spelling, see the Checking the spelling in your Web site section
in the Adding Content to a Web Site chapter of this book.

• Using the Reports view, verify that all the hyperlinks are valid. For more
information on checking links, see the Managing hyperlinks on your Web site
section in the Connecting Pages chapter of this book.

• Using the Tasks view, verify that all tasks have been completed.

• Your Internet or intranet provider should have FrontPage 2000 Server
Extensions to support the publishing of your Web site. For information, see
http://www.microsoft.com/frontpage/, and click Find an Internet Service
Provider that Fully Supports FrontPage. You'll also need to know the ISP's
Web server location for publishing your Web, and your user name and
password, if necessary. Although it is easier to publish your Web site on a
server with FrontPage Server Extensions, you can also publish to a non-
FrontPage Server Extension server using FTP.

• Make sure your Web site is ready for publishing by checking for broken
hyperlinks, verifying that the pages look the way you want them to, and
testing the Web to make sure that everything works. A good way to ensure
your Web is ready is by previewing it in a Web browser and navigating
through the site, and then by reviewing the status of your files in Reports
view.

What you will do:

4 Publish your Web.

4 Learn about
where to publish
your Web.

4 Visit the
Microsoft
FrontPage Web
site.

4 Update your Web.
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Understanding server extensionsUnderstanding server extensions

There are several benefits to publishing to a Web server with FrontPage Server
Extensions:

• Your Web will have full FrontPage 2000 functionality when it is published.
Without the server extensions, advanced server-side features will not work,
including form handlers, search, hit counters, discussion webs, and
component features.

• FrontPage 2000 maintains your files and hyperlinks—each time you publish
the Web, FrontPage2000  compares the files on your local computer to the
files on the Web server. For example, if you move a file in your local Web,
FrontPage 2000 updates and corrects any hyperlinks to it, and then makes
the same corrections to the files on the Web server the next time you publish
the Web.

• After you have published the Web, you will be able to edit it directly on the
ISP's Web server (however, the local version of your Web will not remain in
sync).

• If your Web server has FrontPage Server Extensions, FrontPage 2000 can
publish your Web using HTTP (HyperText Transfer Protocol). Otherwise, your
Web will be published using FTP (File Transfer Protocol).

• Finally, Office 2000 applications can save files directly to your FrontPage-
based Web site if the Web server has the FrontPage 2000 Server Extensions
installed.

Understanding Web site publishingUnderstanding Web site publishing

If your ISP has given you a size limit on the Web server, file management is a
necessity. You can keep the size of your Web down by deleting old files, especially
those with many graphics. Use the Reports view to run a report on Older Files. With
this report, you can know which files are old. Once you have published a Web,
FrontPage 2000 can synchronize the files on your local Web with the published files
on the Web server, each time you publish again.

After you delete files on your computer, FrontPage 2000 prompts you about deleting
the same files on the Web server when you publish your Web again, and you can
choose to publish only pages that have changed.

If your Web server uses FrontPage Server Extensions, FrontPage 2000 can also
match other actions on the Web server, such as moving or renaming files, the next
time you publish your Web. FrontPage 2000 updates your navigation bars, shared
borders, and hyperlinks on the Web server to match the actions you performed on
the Web on your computer.
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Choosing a location for your Web siteChoosing a location for your Web site

With FrontPage 2000, you can save your Web in multiple places at once. You can
create your Web on a hard disk, network drive, or Web server. Note that only
publishing to a Web server makes the Web site available on the World Wide Web.

You can publish or save your Web to the following locations:

• Your hard disk or a network drive. Type the path or file location. Keep in
mind that others who use your computer or are on your network can
view, open, and change these files through the file system. Be sure to
store your Web site in a subdirectory on your hard drive, not at the root
directory (for example, in c:\my Webs\ rather than c:\). That way, if you
ever need to delete the Web, you delete a file folder instead of having to
select files from the root directory.

• Your Personal Web Server. If the name of your personal computer is
"Central High" you can create a Web to http://Central High/School Web.
Personal Web Servers allow you to create Webs and test Web
functionality on your own computer. Microsoft Personal Web Server
ships with Microsoft Windows 95 and Windows 98, or is available for
download in the Windows NT Option Pack.

• Your school intranet server. An intranet is a Web or series of Webs that
are available only within a particular networked environment. For
example, in a school district, schools may create their own Web pages
and then publish these pages to a computer running Web-server
software. People on the network can view the pages by typing in a path
such as http://DistrictWeb/ (intranet addresses don't contain the "www"
prefix).

• A World Wide Web server. The World Wide Web is made up of an
enormous network of servers located all over the world, all accessible
using a Web browser. Web servers that "host" sites that are viewable on
the World Wide Web may exist within your own district or school, or
schools contract with a Web hosting provider or Web presence provider
to host their site.

Choosing files to publishChoosing files to publish

You can choose which files to publish, and which ones not to publish. For instance, if
a page is incomplete, you can mark the file so that it doesn’t get published. Later, if
you decide to publish the file, you can change its publishing status.

You can also choose to publish only those files that have changed. FrontPage 2000
compares the files in the working Web on your local computer to the published files
on the Web server. If FrontPage 2000 detects a newer version of a file on your local
computer, the file is published to the Web server.



66  Publishing a Web Site In and Out of the Classroom with FrontPage 2000

Marking the pages to publishMarking the pages to publish

You can specify which files you want to publish. FrontPage 2000 automatically
marks files for publication, but you can change this setting. For example, if you
have not finished editing a page but you want to publish your Web site, you can
prevent the page from being published by marking it as “Don't Publish.” When
you want to publish the file, mark the page “Publish.”

To mark a page to exclude from publishingTo mark a page to exclude from publishing

1. Select the file you want to mark as excluded from publishing and right-
click on the file.

2. Click Properties on the shortcut menu, and then click the Workgroup
tab.

3. To prevent a file from being published, select the Exclude this file when
publishing the rest of the web check box.

To mark a page to include in publicationTo mark a page to include in publication

1. Select the file that you previously marked as excluded from publishing
and right-click on the file.

2. To mark a file for publishing, clear the Exclude this file when publishing
the rest of the web check box.

Viewing the publishing status of filesViewing the publishing status of files

You can view the publishing status of all the files in a Web by running a report.
The Publish Status report indicates whether a file has been marked as “Publish”
or “Don't Publish.” All files are marked as “Publish” unless you change the
status.

To view the publishing status of filesTo view the publishing status of files

1. On the View menu, click the Reports button to go to Reports view.

2. On the Reports toolbar, select from Publish Status the drop-down list.

3. The Publish column displays the publishing status of each file.

You can right-click the page
icon from the Folder List in
any view, click Properties
on the shortcut menu, and
then click the Workgroup
tab.
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Publishing your Web sitePublishing your Web site

With FrontPage 2000, you can use two methods of publishing to your Web hosting
service—Front Page Server Extensions or FTP (file transfer protocol). Both work, but if
your Web hosting service has FrontPage Server Extensions, you can publish your Web
by just entering the Web site’s address as you would when viewing it in your browser.
If FrontPage Server Extensions are not installed on the server, you can use FTP (file
transfer protocol) to copy the files to the server.

You also have the following options regarding how to publish the files:

• Publish only the files that have changed. FrontPage 2000 compares the
files on your local Web to the files on the Web server, and only those files
that are newer than those on the Web server are published. However, files
that have been marked Don't Publish are not published.

• Publish all files, except those that have been marked Don't Publish. The
files from the local Web overwrite all files on the destination Web server,
even if the files on the Web server are newer.

• Publish subwebs if the current Web has subwebs. All files and folders in
subwebs are recursively published in addition to those in the current Web.

• Publish the Web using a secure (SSL) connection. For example, use this
feature if your Web server uses the HTTPS protocol to authenticate its users.

Publishing to HTTP, FTP, or a file systemPublishing to HTTP, FTP, or a file system

Publish using HTTP (HyperText Transfer Protocol) if the FrontPage Server
Extensions are installed on the Web server to which you are publishing.

Publish using FTP (File Transfer Protocol) if the FrontPage Server Extensions are
not installed on the Web server to which you are publishing. If you have not
already added the FTP location, you need to know the FTP server name and
directory path.

You can publish your Web to a folder on your local file system or to a UNC path.
For example, you can make a backup copy of your entire Web by publishing it to
a new disk-based location, such as C:\Backup. Publishing a Web rather than just
copying files ensures that all necessary files are saved and in the correct
structure.
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To publish your Web siteTo publish your Web site

1. On the File menu, click Publish Web. The Publish Web dialog box
appears.

2. Click Options to expand the list of options.

3. Specify whether you want to publish only pages that have changed, or all
pages.

4. To publish subwebs, select the Include subwebs check box. All files and
folders of the subwebs in the current Web is published recursively, in
addition to the files and folders of the current Web.

5. In the Specify the location to publish your Web to box select the
location you want to publish to:

• HTTP. Type the location of a Web server, click the arrow to select a
location to which you have published before, or click Browse to find
the publishing location.

• FTP. Type the FTP server location (ftp://ftp.server.com/~folder) in
the Publish Web dialog box (be sure to type ftp:// before the server
name), and then type your user name and password in the dialog
box that appears. To find an FTP site, click Browse, click the FTP
site in the Look in box, and then click Open.

• File system. Type the path to the folder on your file system, such as
C:\MyWebs or \\Webs\Myfolder. To find the folder, click Browse.

6. To publish using a secure connection when publishing with HTTP, select
the Secure connection required (SSL) check box. Your destination Web
server must support SSL for this feature to work.

7. Click Publish. FrontPage 2000 publishes your Web. If you cancel
publishing in the middle of the operation, files that have already been
published remain on the destination Web server.

Adding or changing an FTP locationAdding or changing an FTP location

When you publish your Web to an FTP location, you can set up the FTP location,
and your user name and password, in advance. Then, whenever you publish your
Web, your login information is provided automatically. After adding an FTP
location, you can change it, for example to update your password.

Before you can set up an FTP location, you need to know the FTP server name
and directory path. The FTP server name is the domain name of the Web server
to which you are publishing (for example, ftp.server.com). The directory path is
the folder on the server where your Web is stored (for example, /www). If you are
unsure about your user name, password, or FTP location, contact your Internet
service provider.

To publish only pages that
have changed to the same
location you previously
published to, click Publish

.

If you are publishing to a
Web server without
FrontPage Server
Extensions, you are notified
of any features that require
the server extensions.
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To add, change, or delete an FTP locationTo add, change, or delete an FTP location

1. On the File menu, click Publish Web.

2. Click Browse.

3. In the Look in box, click FTP Locations.

4. Double-click Add/Modify FTP Locations.

5. To add an FTP location, do the following:

• In the Name of FTP site box, type the FTP server name and directory
path, for example ftp.server.com/www, and click Add.

• Under Log on as, specify whether you want to log on to the FTP
server as an anonymous user, or specify your user name and
password. Then, click Add.

6. To modify an FTP location, do the following:

• Under FTP sites, click the site to modify.

• Under Log on as, change the settings as needed, and then click
Modify. If you want to change the FTP site name, you must add the
site as a new FTP location.

7. To remove an FTP location: Under FTP sites, click the site, and then click
Remove.

Deleting a file or folder that has been publishedDeleting a file or folder that has been published

When you publish your Web, FrontPage 2000 compares the current files on your
local computer to those files on the Web server. To manage files on the Web
server (for example, to get rid of old files or folders), delete or move the files or
folders in the Web on your local computer. FrontPage 2000 then prompts you
about which files to delete on the Web server the next time you publish.
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Extending your knowledgeExtending your knowledge

Publishing your Web is like orchestrating a complicated performance. Although
FrontPage 2000 makes Web publishing simple, it takes planning and coordination to
make everything work. Web maintenance doesn’t stop once your Web is published.
Because information changes, updating your Web periodically is critical.

Updating your WebUpdating your Web

At it’s best, a Web should contain current information. To keep your Web up-do-
date, you need to upload new information whenever necessary. If you need to
make a lot of changes, you use the same procedure to upload the new files that
you used when you first published your Web. If you have any questions regarding
this procedure, contact your network administrator.

Publishing changed pagesPublishing changed pages

If you are publishing a FrontPage Web that has been published at least once
before, use the following method to copy only those pages that have been edited
since the last time you published or copied the FrontPage Web.

To copy to the serverTo copy to the server

1. On the File menu, click Preview in Browser, and click Preview.

2. On the File menu, click Close.

3. Click the Publish FrontPage Web button.

4. In the Publish dialog box, click OK.
- or -
If you want to change the location, click More Webs.

5. Save your changes and close FrontPage 2000.
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Exploring the Microsoft FrontPage Web siteExploring the Microsoft FrontPage Web site

Look over the Microsoft FrontPage home page, and explore some of the links.
The site provides product and resource information you can download and is
updated frequently with upgrades, educational support and exchanges, technical
help, and many other types of useful information.

To go to the Microsoft FrontPage Web siteTo go to the Microsoft FrontPage Web site

1. Open your Web browser and type http://www.microsoft.com/frontpage/
in the Address box, and then press ENTER.

2. Follow the link to the MSDN Online Web Workshop and check out the
collection of tips and tricks and how-to articles for FrontPage 2000.

3. Select the Office Update link from the FrontPage Web site to find free
downloads, updates, and assistance for FrontPage 2000.

4. Click the links to view pages in the Web site.

5. To download information, see your network administrator.


